Сценарий Взятие\Снятие раздела в Орион про.

FORUM_NAME: АРМ Орион Про версии до 1.20
Описание: АРМ "Орион Про" — пакет программного обеспечения для аппаратно-программного комплекса ИСО "Орион", на котором реализуются системы охранной сигнализации, контроля и управления доступом, охранного видеонаблюдения, автоматика противопожарных систем, сопряженные с инженерными системами объектов.
Справочная информация, руководства для АРМ Орион Про версии до 1.20
Модератор: Модераторы
Koresh
Автор темы
Koresh
Автор темы
Репутация: 0
Сообщения: 3
Зарегистрирован: 27.05.2013
С нами: 3 года 6 месяцев
Профессия: Инженер

Непрочитанное сообщение #1 Koresh » 17.07.2013, 13:26

Здравствуйте. Экспортировал базу из Орион в Орион ПРО. В Орионе к считывателям были привязаны сценарии "Взятие\снятие раздела с охраны", который (вроде бы) меняет состояние раздела на противоположный при поднесении брелка. Но в ПРО такого шага нет, есть отдельно снятие и взятие раздела. Как в Про сделать так же? И в Орионе привязка такого сценария шла к пункту "Идентификация" считывателя, но в ПРО такого пункта нет, куда привязывать? Спасибо

lamyk
lamyk
Репутация: 0
Сообщения: 90
Зарегистрирован: 17.04.2013
С нами: 3 года 7 месяцев
Профессия: Наладчик

Непрочитанное сообщение #2 lamyk » 17.07.2013, 18:51

как нет? C:\BOLID\ARM_ORION_PRO1_12\DOC\SCRIPTS
Спойлер

Код: Выделить всё

// Пример смены состояния нескольких шлейфов (выборочно) на противоположное

Сценарий
  Переменные
    Перем Шлейфы1;

НачалоСценария

  // Создание объекта Шлейфы для последующей манипуляции
  Шлейфы1 = СоздатьОбъект("Шлейфы");

  // Проверка наличия шлейфов в коллекции
  Если Не ПустоеЗначение( Шлейфы1 ) Тогда

    // Смена состояния шлейфа с адресом 1.1.11.2
      // Проверка шлейфа на существование
      Если Не ПустоеЗначение( Шлейфы1.ПолучитьПоАдресу( "1.1.11.2" ) ) Тогда

        //Проверка состояния шлейфа
        Если Шлейфы1.ПолучитьПоАдресу( "1.1.11.2" ).Состояние() == "СНЯТ" Тогда

          // Взятие раздела на охрану
          Шлейфы1.ПолучитьПоАдресу( "1.1.11.2" ).Взять();

        Иначе

          // Снятие раздела с охраны
          Шлейфы1.ПолучитьПоАдресу( "1.1.11.2" ).Снять();

        КонецЕсли;

      КонецЕсли;


    // Смена состояния шлейфа с ИД 533
      // Проверка шлейфа на существование
      Если Не ПустоеЗначение( Шлейфы1.ПолучитьПоИД( 533 ) ) Тогда

        //Проверка состояния шлейфа
        Если Шлейфы1.ПолучитьПоИД( 533 ).Состояние() == "СНЯТ" Тогда

          // Взятие раздела на охрану
          Шлейфы1.ПолучитьПоИД( 533 ).Взять();

        Иначе

          // Снятие раздела с охраны
          Шлейфы1.ПолучитьПоИД( 533 ).Снять();

        КонецЕсли;

      КонецЕсли;

  КонецЕсли;
   
КонецСценария
Вложения
Снимок.JPG

Koresh
Автор темы
Koresh
Автор темы
Репутация: 0
Сообщения: 3
Зарегистрирован: 27.05.2013
С нами: 3 года 6 месяцев
Профессия: Инженер

Непрочитанное сообщение #3 Koresh » 22.07.2013, 00:52

Большущее спасибо, все заработало ) Не знал про такую папочку с примерами скриптов.


  • Похожие темы
    Ответы
    Просмотры
    Последнее сообщение

Вернуться в «АРМ Орион Про версии до 1.20»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 4 гостя

forum-bolid.ru : Отказ от ответственности